Application speed issues

Incident Report for Qhub

Resolved

Root causes have all been resolved and platform stability confirmed.
Posted Sep 10, 2026 - 14:46 BST

Monitoring

A fix has been implemented. We are monitoring the performance.
Posted Sep 10, 2026 - 09:10 BST

Identified

The Q-hub system auto scales up its capacity and servers as load increases by customer usage. We have identified a problem with the autoscaling, a fix is being implemented
Posted Sep 10, 2026 - 09:00 BST

Investigating

Reports of application speed and internal alerts indicate an abnormal issue in load times for certain application pages and users.
The Issue is under investigation with the development team.
Posted Sep 10, 2026 - 08:53 BST
This incident affected: Q-hub platform (UK).